Configuring RIP on Juniper M20 / M40 router
In this tutorial:
Configure RIP on Juniper.
Configure routing policy for
RIP routes to transit through Juniper router.
View routes learned on Cisco
and Juniper.
Topology:
Configuration on JunOS
#Step 1 : Host name for Juniper M40
set system host-name JunOS
#Step 2 : interface ip address
set interface lo0.0 family inet address 2.2.2.2/32
set interface em0.0 family inet address 10.1.2.2/24
set interface em1.0 family inet address 10.2.3.2/24
#Step 3 : Create policy to transit RIP routes through JunOS
edit policy-options policy-statement RIP_ROUTE
set term RIP_TRANS_ROUTE from protocol rip
set term RIP_TRANS_ROUTE then accept
set term DIRECT from protocol direct
set term DIRECT then accept
#Step 4 : RIP configuration on JunOS
edit protocol rip group NEIGHBOURS
set export RIP_ROUTE
set neighbor em0.0
set neighbor em1.0
top
#Step 5 : Commit changes
commit
Show configuration on JunOS
[edit]
root@JunOS# show | find interface
interfaces {
em0 {
unit 0 {
family
inet {
address 10.1.2.2/24;
}
}
}
em1 {
unit 0 {
family
inet {
address 10.2.3.2/24;
}
}
}
lo0 {
unit 0 {
family
inet {
address 2.2.2.2/32;
}
}
}
}
protocols {
rip {
group
NEIGHBOURS {
export
RIP_ROUTE;
neighbor em0.0;
neighbor em1.0;
}
}
}
policy-options {
policy-statement RIP_ROUTE {
term
RIP_TRANS_ROUTE {
from
protocol rip;
then
accept;
}
term DIRECT
{
from
protocol direct;
then
accept;
}
}
}
[edit]
root@JunOS#
Configuration on Cisco Router 1
Router1#show configuration | begin interface
interface Loopback1
ip address 1.1.1.1
255.255.255.255
!
interface Loopback10
ip address
11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
ip address
10.1.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
network 11.0.0.0
no auto-summary
!
Configuration on Cisco Router 2
Router2#show configuration | begin interface
interface Loopback1
ip address 3.3.3.3
255.255.255.255
!
interface Loopback10
ip address
33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
ip address
10.2.3.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 3.0.0.0
network 10.0.0.0
network 33.0.0.0
no auto-summary
!
Verify the routes on JunOS with show cmd
root@JunOS> show route protocol rip
inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
1.1.1.1/32 *[RIP/100] 00:38:34, metric 2, tag 0
> to 10.1.2.1 via em0.0
3.3.3.3/32 *[RIP/100] 00:30:12, metric 2, tag 0
> to 10.2.3.3 via em1.0
11.11.11.11/32 *[RIP/100] 00:38:34, metric 2, tag 0
> to 10.1.2.1 via em0.0
33.33.33.33/32 *[RIP/100] 00:30:12, metric 2, tag 0
> to 10.2.3.3 via em1.0
224.0.0.9/32 *[RIP/100] 00:18:56, metric 1
MultiRecv
root@JunOS>
root@JunOS> show route protocol rip
inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
1.1.1.1/32 *[RIP/100] 00:38:34, metric 2, tag 0
> to 10.1.2.1 via em0.0
3.3.3.3/32 *[RIP/100] 00:30:12, metric 2, tag 0
> to 10.2.3.3 via em1.0
11.11.11.11/32 *[RIP/100] 00:38:34, metric 2, tag 0
> to 10.1.2.1 via em0.0
33.33.33.33/32 *[RIP/100] 00:30:12, metric 2, tag 0
> to 10.2.3.3 via em1.0
224.0.0.9/32 *[RIP/100] 00:18:56, metric 1
MultiRecv
root@JunOS>
Verify the routes on Cisco with show cmd
Router1#show ip route rip
# ---- Output truncated ---- #
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.1.2.2, 00:00:01, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/2] via 10.1.2.2, 00:00:01, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.2.3.0/24 [120/1] via 10.1.2.2, 00:00:01, FastEthernet0/0
33.0.0.0/32 is subnetted, 1 subnets
R 33.33.33.33 [120/2] via 10.1.2.2, 00:00:01, FastEthernet0/0
Router1#
Router2#show ip route rip
# ---- Output truncated ---- #
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/2] via 10.2.3.2, 00:00:02, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.2.3.2, 00:00:02, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.2.3.2, 00:00:02, FastEthernet0/0
11.0.0.0/32 is subnetted, 1 subnets
R 11.11.11.11 [120/2] via 10.2.3.2, 00:00:02, FastEthernet0/0
Router2#
# ---- Output truncated ---- #
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.1.2.2, 00:00:01, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/2] via 10.1.2.2, 00:00:01, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.2.3.0/24 [120/1] via 10.1.2.2, 00:00:01, FastEthernet0/0
33.0.0.0/32 is subnetted, 1 subnets
R 33.33.33.33 [120/2] via 10.1.2.2, 00:00:01, FastEthernet0/0
Router1#
Router2#show ip route rip
# ---- Output truncated ---- #
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/2] via 10.2.3.2, 00:00:02, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.2.3.2, 00:00:02, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.2.3.2, 00:00:02, FastEthernet0/0
11.0.0.0/32 is subnetted, 1 subnets
R 11.11.11.11 [120/2] via 10.2.3.2, 00:00:02, FastEthernet0/0
Router2#
Disclaimer
Information above is either from RFCs or it's Googled. This blog is result of my enthusiasm, desire and hard work to lean networking and share my leanings. Most of the times I’ll be using GNS3 network simulator. All I've here is collection of my findings, thanks to Google. Please do not ask for any of the software from CISCO/Juniper, it's better to Google it and try your luck.
No comments:
Post a Comment